Daylight Saving Time setting Brazil.

Hello, how are you guys?
This year we will not have daylight saving time in Brazil, but my ntp server keeps applying daylight saving time automatically, what should I do to resolve?

Not a NTP server issue, please solve it yourselves by updating your client system. For example, on Windows you should check kb4507704 and get the appropriate update package for your system to remove the obsolete DST setting.

@alica installed kb4507704 on computers that were applying daylight saving time, somehow it seems to work, but the ntp server stays with daylight saving time.

Do you mean the machine running NTP service reporting DST? What OS is it running on? If on Linux, you should update your timezone package (tzdata or zoneinfo) to update its DST setting.

What OS is the NTP server? For most linux distros there was a tzdata update around July that fixed Brazil. Though if you are no longer observing DST then you could also set it to one of the more “generic” fixed timezones (i.e. GMT-3).

Hello, some linux distribution information.

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 6.0 (squeeze)
Release: 6.0
Codename: squeeze

Uname -a command output
Linux prjarq938v 2.6.32-5-686-bigmem # 1 SMP Wed Jan 12 04:40:25 UTC 2011 i686 GNU / Linux

best regards,
Wesley Santos

This page might help: https://wiki.debian.org/TimeZoneChanges

Debian look to have updated for Brazil in “2019b-0+deb9u1” in September: https://launchpad.net/debian/+source/tzdata/2019b-0+deb9u1

But Debian Squeeze has been EOL for years, so you have to backport security fixes and time zone updates and other changes yourself, until you upgrade to a supported version of Debian.

@elljay @mnordhoff

This debian server runs my PDC Samba, it is very critical to update at this time. I ended up changing the time zone to one that was using my city time zone, so it’s serving me.

best regards,
Wesley Santos

The tzdata package from buster requires only debconf >= 0.5
You can try to install this to have the latest time zone data.
https://packages.debian.org/buster/tzdata

Hi sorry for the delay, I tried to download the .deb package, but did not find this option, run the command “dpkg -l | grep debconf”, which states that the “debconf 1.5.36.1” package is already installed

best regards,
Wesley Santos

Hey Wesley,

did you mean you need to know how to install the deb package or does it return an error during installation ?

download the debfile
run (sudo) dpkg -i tzdata_2019b-0+deb10u1_all.deb to install the file
to re-configure the timezone run (sudo) dpkg-reconfigure tzdata

Hello, I did not find the link to download the correct .deb file.

Ahh ok,

you can use the above link, scroll on the new page down to Architecture and click on all. There you will get some donwload links.

Or use this link from a german mirror
http://ftp.de.debian.org/debian/pool/main/t/tzdata/tzdata_2019b-0+deb10u1_all.deb

Hello, I downloaded the package “tzdata_2019b-0 + deb10u1_all.deb”, but an error occurs during the installation “dpkg -i tzdata_2019b-0 + deb10u1_all.deb”.

Captura%20de%20tela%20de%202019-11-13%2009-10-36

best regards,
Wesley Santos

Did you run the command as root or either via sudo ? dpkg requires root permission.

If this dosen’t work elljay posted the Debian Wiki link. There are steps how to modify the tzdata

I ran the command as root.
Can you send the link elljay posted for tzdata update?

best regards,
Wesley Santos