Only one pool for IPv6 in AT, DE, CH


#1

Dear All,

I just figured out there is only one pool which delivers IPv6 addresses in Austria. It is 2.at.pool.ntp.org
If I run a “dig” for the others ( 0, 1, 3 ) I don’t get a result.
The same for Germany and Switzerland.
Is this normal ?
Actually there are enough server available to fill all of them with IP addresses.

Kind regards
Hans


#2

It is. You can check old thread about IPv6 zone and its limitation in availability.


#3

Hi aliaca, many thanks pointing my to the information. // Hans


#4

I just checked and run several times
dig at.pool.ntp.org aaaa +short
and I never got an answer. Of course I get four IP’s for
dig 2.at.pool.ntp.org aaaa +short
If I run
getent hosts at.pool.ntp.org
which goes over nsswitch library I only get IPv4 and never IPv6

Do I get explicitly a mixture of v4 and v6 if I select a “2”-poll ?
Is this what it should be ? I can’t believe.

// Hans


#5

To answer your question, yes, it is normal that only 2.*.pool.ntp.org has AAAA records.

For reference: https://news.ntppool.org/2011/06/continuing-ipv6-deployment/


#6

Hi avij,

Many thanks for your answer.
Assuming there is an IPv6-only network.
As administrator there you have a difficult life.

// Hans


#7

No, it depends on your client.

They’ll either just do one or the other or do both (and thus twice as many servers). The failure modes are “configuring too many servers” (not terrible, but dumb and adding extra load to the system for little gain) or worse “configures only IPv6 when that isn’t working on the local network”.