How can I set up NTP Pool in local?

Oops – apologies for that. I appreciate you trying to get it running so others than me try it out!

MaxMind changed the geoip databases to require authentication to update the databases.

The values.yaml configuration for the NTP Pool needs some configuration for that. I made an issue to remind myself to fix the documentation. Document geoip configuration in ntppool chart · Issue #1 · ntppool/charts · GitHub

In my environment I use Vault to store secrets (including the MaxMind API key); the config script is where the vault agent writes the secret.

The format of the secret (it can be mounted as a kubernetes secret) needs to be


Untested, but if you are willing to give it a try this might help you get a little further:

Put the contents above in a file (with configuration from MaxMind instead of the sample values) named and then create a secret with

kubectl create secret generic geoip-keys

In the NTP Pool values.yaml you then configure the geoip container with something like:

      enabled: true
      mountPath: /var/geoip-keys/
      name: geoip-keys
      type: secret