Can't log in with GitHub + help form broken

I can’t log in to manage dot ntppool dot org, manage-beta dot grundclock dot com or community dot ntppool dot org with GitHub using Chrome on Linux.

Anyone else having issues? The Auth0, Discourse, GitHub and NTP Pool status pages are all green.

A couple people I asked were able to create accounts or log in, but they aren’t using GitHub.

For the manager, I click on “Continue with GitHub”, GitHub authorizes it, and then I get redirected back to the login page like nothing happened.

For Discourse, I get redirected back to Discourse and it says “Sorry, there was an error authorizing your account. Please try again.”

Additionally, the “If you need help loggin in” form on manage dot ntppool dot org submits to a domain with an invalid certificate, and which just says “default backend - 404” if you bypass the certificate error.

Additionally additionally, I got the same “Sorry, there was an error authorizing your account. Please try again.” error signing up for this Discourse account using my email address, but it worked anyway.


Hi Matt – I tried just now and the GitHub login worked. Can you send timestamps for when you tried and the IP your request might have come from (email is good if you don’t want to share your IP with the world…) and I’ll find it in the logs.

(And eek on the other help form not working; I should have realized that it wasn’t getting any emails for a while!)

For posterity:

Thank you for responding! I sent you an email @

For posterity again:

I was emailing Ask back and forth, got an idea, and fixed the problem.

I can log into the Pool and Discourse with GitHub now.

The problem was, in my GitHub account, my email address was marked “Undeliverable” and “Unverified”. I don’t know why. Maybe it was because my provider had some outages recently.

(Regardless, GitHub never stopped sending me emails.)

I reverified the email address and now it works.

Since the NTP Pool requests the email address, GitHub must have been blocking the logins in lieu of returning “unverified” information.

I wish GitHub (or Auth0) had given me (or the Pool) an error message explaining the problem instead of silently proceeding!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.