Weird problem with my public NTP server

OK guys, so I have public NTP server, and it was installed on Fedora 30. I needed to change to Ubuntu, so I made new configuration to Ubuntu 18.04.3 LTS. But here is the thing, I installed the NTP, and no matter what NTP servers I am choosing, it is OK for a 3-4 minutes, and then I can see with ntpq -p that somehow the sync servers are changed with only this:

This is third day that I am struggling… Here is my config file. I am lost, I will appreciate any help.

# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift
Leap seconds definition provided by tzdata

leapfile /usr/share/zoneinfo/leap-seconds.list
Enable this if you want statistics to be logged.

statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable
Specify one or more NTP servers.
Use servers from the NTP Pool Project. Approved by Ubuntu Technical Board
on 2011-02-08 (LP: #104525). See for
more information.

server iburst
server iburst
server iburst
server iburst
Use Ubuntu’s ntp server as a fallback.
Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
details. The web page
might also be helpful.
Note that “restrict” applies to both servers and clients, so a configuration
that might be intended to block requests from certain clients could also end
up blocking replies from your own upstream servers.
By default, exchange time with everybody, but don’t allow configuration.

restrict -4 default kod notrap nomodify nopeer noquery limited
restrict -6 default kod notrap nomodify nopeer noquery limited
Local users may interrogate the ntp server more closely.

restrict ::1
Needed for adding pool entries

restrict source notrap nomodify noquery
Clients from this (example!) subnet have unlimited access, but only if
cryptographically authenticated.

#restrict mask notrust
If you want to provide time to your local subnet, change the next line.
(Again, the address is an example only.)

If you want to listen to time broadcasts on your local subnet, de-comment the
next lines. Please do this only if you trust everybody on the network!

#disable auth

#Changes recquired to use pps synchonisation as explained in documentation:

#server mode 135 prefer # Meinberg GPS167 with PPS
#fudge time1 0.0042 # relative to PPS for my hardware

#server # ATOM(PPS)
#fudge flag3 1 # enable PPS API’


maybe your configuration will be overwritten / added by dhclient.
Search for “ntp-servers” in /etc/dhcp/dhclient.conf
It should be in a line which starts with “request”.
If you remove this part no servers will be added to your configuration by dhcp request.

(ps. would be nice if you could add your above quoted text into “preformatted text” (</> Button))

Thank you very much ! It did not occurred to me, that my Mikrotik’s SNTP client was synched to !

Sorry for the inconvenience, I edited the post with “preformatted” text.

Again, thank you !