Server started keeping a bad time


#1

Hi all,

So I’ve been providing NTP services for some time now and out of nowhere things start to change. So the bad time mails started to show up and right now the score is below 0.

User page: http://www.pool.ntp.org/user/vtfitdx4832cb9qgxn

And this is ntpq:
$ ntpq -c pe -n
remote refid st t when poll reach delay offset jitter

195.234.155.124 194.58.203.148 2 u 900 1024 17 7.846 14.435 10.227
2a00:c98:2050:a 80.127.147.170 2 u 872 1024 17 17.992 15.589 10.705
87.237.210.147 194.58.203.20 2 u 896 1024 17 29.431 17.974 10.173
109.236.81.11 193.67.79.202 2 u 905 1024 17 16.069 17.401 11.315

I tried to change servers and restarted the ntp service. It didn’t work out.

Anyone got any ideas to sort this out?


#2

$ ntpdate -qu 193.104.228.123
1 Dec 00:47:28 ntpdate[29130]: 193.104.228.123 rate limit response from server.
server 193.104.228.123, stratum 3, offset 0.003960, delay 0.04890
1 Dec 00:47:28 ntpdate[29130]: adjust time server 193.104.228.123 offset 0.003960 sec

$ ntpdate -qu 2001:67c:28c8:12::123
1 Dec 00:50:12 ntpdate[29280]: 2001:67c:28c8:12::123 rate limit response from server.
server 2001:67c:28c8:12::123, stratum 3, offset 0.004194, delay 0.04915
1 Dec 00:50:12 ntpdate[29280]: adjust time server 2001:67c:28c8:12::123 offset 0.004194 sec

What kind of rate limiting configuration do you have? Is this a physical or a virtual server? If a virtual server, which virtualization system?


#3

Sorry for the late reply.

I have limited in my restrict config, but i haven’t setup a rate-limit. So I guess it’s default?

I have looked into documentation on this and have no clue what options to set to discard. Should i just use discard monitor 5000?

Its a virtual Ubuntu running on VMWare with tools where time sync is disabled.


#4

Looks much better now.


#5

I haven’t done anything. With the next 14 days my guess is that it will happen again.


#6

And we are at -20 again.


#7

There are entries in the log that show your server being some 270 seconds off. Do you manage that VMWare setup yourself, or do you buy the service from somewhere else? If it’s managed by someone else, perhaps the VMs get transferred between hosts every now and then, and some hosts have flaky timekeeping.