I want to add my NTP server. But I can't


I want to join in NTP Pool But I can’t.

I saw this message.

You can see my static IP.

OS : Ubuntu 20.04 LTS Server

I opened ufw allow 123/udp.

And I followed recommended configuration in NTPPool Project.

Help Me. Please.

And Thank you for spare your time.

1 Like does not respond to NTP requests from the NTP Pool monitor
1 2022-03-15 09:28:51.598944 → NTP 90 NTP Version 4, client
2 2022-03-15 09:31:22.827602 → NTP 90 NTP Version 4, client
3 2022-03-15 09:40:45.946190 → NTP 90 NTP Version 4, client
4 2022-03-15 09:41:07.818160 → NTP 90 NTP Version 4, client
traceroute reaches and stops.

Perhaps Korea University, who owns the IP address, blocks NTP (UDP port 123)

1 Like

Simple check reveils all.

Your port seems to be blocked.

1 Like

Looks like it’s working now and he was able to join the pool :slight_smile:


Thank you! All the answer!

1 Like

Dear all

I also tried to add my Server but I am facing 2 issues.

First issue:
ntpd seems not answering to IPv6 requests.
See Screenshot:

second issue:
I get error message while adding the Server:
nvalid stratum response from (Your server is in stratum 0). Is your server configured properly? Is public access allowed? If you just restarted your ntpd, then it might still be stabilizing the timesources - try again in 10-20 minutes.

Anyone able to assist?
I checked Firewall Config - should be fine.
i can also provide access to the server if someone wants to check himself/herself.

many thanks and best regards

Yves, welcome to the community!

Your server has no working time synchronization source. That is important thing to fix.

1 Like


I have following Sources:

server ntp0.as34288.net iburst
server ntp.freestone.net iburst
server ntp1.as34288.net iburst
server tick.ntp.infomaniak.ch iburst

Where to fix?

Hi yves,

it looks like your ntpd isn’t synchronized (stratum 16) and isn’t listening on the ipv6 address behind the hostname (either the ipv6 is wrong or ntpd isn’t listening)
What is the output of ?:
ntpq -pn
ss -lup
journalctrl -u ntpd |grep -i listen
(maybe the ntp instead of ntpd - didn’t remember the service name)
Maybe you start a new thread, so you won’t “hijack” this one to debug your problem.

1 Like

Yves and I discussed off-list. He got IPv4 working. IPv6 works at the server, but is being blocked by by a local firewall. Still under study.

1 Like

Dear all

Problem was one Switch in between.
a Huawei S1720 was blocking some packets.

With “ntp ipv6 forward-mode hardware” it could be solved.

Many thanks to all