Happy 10th anniversary of World IPv6 launch Day!


1 Like

Sorry Marco,

I killed IPv6 on most of my servers again.
Only the datacenter servers still run it.

As my router assigns a new IPv6 with every new NIC-MAC-adress.

I need to reconfigure the Fritzbox every time when a NIC switches and inform the ISP for the reverse-lookup.

This protocol is nothing to be happy about. For me it may be killed and redesigned to make it more user friendly.

It’s designed by a bunch of nerds living on some weird planet where no Humans where present :crazy_face:

They should have extended IPv4 with some extra numbers and leave the way it works upto the user themselves.
Now we are forced to put the NIC public and when it changes it changes the IP as well as forwarding and you end up changing the DNS records also.
There is no easy way to use this dumb protocol.

For me it must be berried and redesigned. If even AVM can’t get it right, they build routers and damn good ones.

Don’t start me on certificates and other crap that you have to do double.
NSLOOKUP’s that don’t work, sometimes they do, often they don’t and just return IPv4 addresses only.

Not even Linux knows what to do with it, most doesn’t even work, or blocks.

IPv6 should die, hopefully tomorrow. :face_with_symbols_over_mouth:


Why do you change MAC addresses? And if you do, why don’t you use fixed IPv6 addresses instead of SLAAC?

I disconnected the onboard Nic and added a better Nic with hardware stamping, so the Mac changes.
I tried static IPv6 in the past, never got it working as it would pass the router.

After spending way too much time the last time, for me IPv6 is finished and burried.

You and IPv6 clearly aren’t very good friends.

It’s okay, don’t worry. Thank you for at least trying (hard).

In a datacenter it’s not a problem, those keep running IPv6 as their IP is fixed no matter what.

But at home it’s a different story as I change hardware often and then IPv6 breaks all the time.

They realy have to rethink this protocol and make it more flexible and simple, it just has too many options and quirks.

Every time when I think I understand it, something happens and it stops working.

Maybe I’m just too dumb for IPv6 :grin:

Truly, @Bas, you’re doing it wrong. If you configure your interface to use a fixed IPv6 address, even when you replace a NIC, everything would just keep on working.

My server, pool.ntp.org: Statistics for 2600:1700:c0:5678::123 uses netplan and all that’s needed is to have such lines in the configuration file for the interface:

- “2600:1700:c0:5678::123/64”


1 Like

When will all ntppool domains have IPv6 records?

Thanks a lot!!!
You actually helped me a lot and it worked.


I just needed to

iface eno1 inet6 static
         address 2a02:578:440e::aaa1:59ff:fe3d:5b53/64

In interfaces, and set the same address in the Fritzbox by portforwarding and it actually works.

That is cool, real cool.

All the sites that gave information made it far to complex.

Thank you.

Little question, do I need to supply a nameserver? As it seems to resolve via IPv4 but also gives IPv6 addresses.
If so, what is the best way? As I like to put nameservers in the networking/interfaces config.


I’m glad that I could be of some help. However, your server seems to use the legacy ifconfig while mine uses netplan, so I can’t help about it.

FWIW, you might consider using a cooler, more private, lower 64 bits of the static address.

Good luck.

It works, solved it by adding the ipv6 nameservers to resolv.conf.

I’m not into netplan yet :slight_smile:

I have to say that AVM Fritzbox Labor software versions have changed a lot.
It must have been those changes and your tips that it works today.

As I did try it all before, with mostly bad results.

1 Like

It seems today we are…but I run AVM Labor firmware and they changed a lot.

Since the last labor (beta) firmware, it’s easy to punch holes in the firewall (port-forwarding), this never worked before.

Looks like I was fighting a router :grin:

As my datacenter servers worked from day 1. :crazy_face:

1 Like


Connection managers are a mess in Linux and distributions change their favorite one often. I just use whatever is the favored one of the day.

Things like these give me an itch to bite the bullet and just switch to FreeBSD.

I tried BSD and you must really hate your life to use that :grin:

I stick with Debian (blackbox) and Mint Mate (desktop), thank you.

Care to share your experience with BSD, please?

It’s terrible.

You can try it in VirtualBox. I doubt you ever want to start it again :slight_smile:

It’s not much more advanced then Slackware at the time…boot and hope for the best but end up dissapointed.

BSD is so far off, that it’s not more then a niche OS that has no momentum or userbase at all.
Why not run Atari TOS? It’s still there and runs, but you keep running into troubles to get it going.

Linux isn’t perfect, but it’s the best there is. And no, Windows or MacOS don’t even come close.
Yes they have a bit more applications. But that doesn’t make them better.

The problem with Linux is that most people don’t know it, or don’t want to try it, else they would have moved to it in a hartbeat.

@Marco, I do have some remarks…yes it works, works great.
But IPv6 does need some better error-messages.
Today I got one, I pinged my second local server and it stated: Destination unreachable: Administratively prohibited

This is message that tells me 100% nothing.
It turned out that I had the IP-wrong, stupid typo.

If it would have told me something like: Are you sure the IP is correct?

Then it would have put me on the right track.

Don’t get me wrong, I found out how it works now, and despite my earlier messages, I do love it now.
I just wished that they would make a clear manual how to start, better error-messages and more clear config options and explanations.

When you reasearch on problems, you often end up with more rubbish then solutions.

You may want to write a manual on how to start and what happens automaticly, as most parameters are unneeded.


Best is to think of IPv6 as just some IPv4 with a lot more addresses (not entirely true off course, but for the sake of simplicity). In that sense ICMPv6 messages are also similar to ICMP. When you make a typo while pinging, you could end up at some firewall that is blocking you. As such the ‘admin prohibited’ response makes sense. In fact, I find it more informative than an ‘are you sure you didn’t make a typo?’ (which is pretty generic and also a bit patronising).

But, like I said; expect more or less the same behaviour with IPv6 as with IPv4 (never seen an ‘are you sure the IP is correct’ there, have we?) and you’re good, for the most part.

Becomming better and better at it, but noticed that routers have many errors and problems with IPv6.
In order to ping a device from the outside, you need to enable ping6 for every device connected to the router.
That is kind of silly.
Also the Fritzbox build in DNS doesn’t supply me with IPv6 adresses when native IPv4 is enabled but IPv6 is also enabled, it simply doesn’t.

Just look:

bas@workstation:~$ nslookup ntp1.heppen.be

Non-authoritative answer:
Name:	ntp1.heppen.be

bas@workstation:~$ nslookup ntp1.heppen.be

Non-authoritative answer:
Name:	ntp1.heppen.be
Name:	ntp1.heppen.be
Address: 2a02:578:440e:0:aaa1:59ff:fe3d:5b53

Router manufacturers still have a lot of work ahead of them.
This behaviour of the modem put me on the wrong track before, now I know it’s the router making mistakes.

It should not matter how I ask the DNS, it should respond with all needed records in my opnion just like Google and do.

Mine does, but you have to be a bit more explicit:

nslookup -type=AAAA example.nl
(don’t worry, applications such as browsers, are)

By the way; I prefer tools such as ‘dig’ for DNS-queries.