San Jose Monitor failed to attach my server

Hi,

This morning the San Jose monitor reports my server ‘i/o timeout’ https://www.ntppool.org/scores/111.198.57.33 , but I have checked everything is okay, my local logs show the clients are requesting successfully, and I have manually tested with clients located in different places in China.

Is the monitor blocked by gfw or something else is wrong? Where can I find the monitor’s ip address to check the route status?

Thank you

No NTP responses seen at San Jose monitor (139.178.70.122) for this server since 2021-09-28 20:54 UTC. NTP queries from several other hosts worked fine however.

Traceroute from San Jose reaches China. Try traceroute from your end.
Also try to ping San Jose

I’ve tried traceroute and ping San Jose, the network is fine. So it’s not blocked by ip address.

I’ve checked raw log from ntpd, requests and responds with San Jose are successful all the time.

Thus the respond packets to San Jose are dropped by network.

I tried sending ntp requests to San Jose, no respond get.

I see a few ping requests from your NTP server at 2021-09-30 02:45 UTC
No NTP responses or requests from your server.

Run traceroute with target UDP port set to 123. The syntax depends on which traceroute version is being used. There may be NTP-specific blockage.

I’m not getting response from the server when requesting synchronization using the ntpdate -q command from a server located in New York.

Thank you Steve, I tried traceroute with UDP, it’s successful, but with UDP port 123, it failed on the next hop of China’s exit gateway.

I think this is a situation I could do nothing about… Is there a way to change a monitor?

Thank you Clock, I searched the log, is your IP addr 159.xx.xx.xx? I think the request and respond are successful on my server’s view, that might be the problem of gateway between China and US…

Additional monitors have been discussed, but I don’t know the status.
I can’t help with China gateway issues.

Correct. I got response from your server from my client in Brazil. It appears to be some blockage on the route used between the US and China.

Works from Sydney:

$ ntpdate -q 111.198.57.33
server 111.198.57.33, stratum 1, offset 0.024923, delay 0.24504
30 Sep 16:24:40 ntpdate[16380]: adjust time server 111.198.57.33 offset 0.024923 sec