Pool.ntp.org down

pool.ntp.org server is unavailable in Azerbaijan Republic.
Seems someone turned off the nearest servers az.pool.ntp.org and ntppoolorg do not redirect queries to another available servers.Could someone here can help to fix this issue?

1 Like

@ask The first server in the az pool seems to have a positive score despite all monitors being unable to reach it for the last 8 hours? Like they all gave up and went “testing” mode before the score actually went below 10, so now it’s in limbo.


active			Score
legacy score	20
overall score	10.7

testing			Score
ussjc1-1a6a7hp	-38.4
nlams1-1a6a7hp	-49.5
... etc. ...

The second server… actually, similar story, but it only went down 5 hours ago, and several monitors are still active.


active			Score
overall score	12.6
nlams1-1a6a7hp	-48.3
deksf2-z4ytm9	-30
fihel1-z4ytm9	-59.8
denue1-z4ytm9	-48

testing			Score
legacy score	15.5
ussjc1-1a6a7hp	-20.2
sgsin1-1a6a7hp	-21
... etc. ...

FWIW, https://status.ntppool.org/ says the number of monitoring probes went down significantly at 2023-08-16 22:00 and even more at 2023-08-17 04:00. Did you mean to change something?

(Edited to add a bit of detail.)

1 Like

Thank you for the reply,
I just want ask someone how can redirect queries to another available servers,because this servers are down now.Time synchronization at this momemt does not work in Azerbaijan.So our customers suffer who uses set top boxes and other network devices.

The NTP Pool is supposed to detect when servers stop working and stop serving them.

It is apparently malfunctioning today.

Since there are no other active servers in the az.pool.ntp.org zone, I believe it should be giving you random servers from the entire asia.pool.ntp.org zone, but it is not.

All you can do is configure your computers to use asia.pool.ntp.org (and e.g. 2.asia.pool.ntp.org) instead of az.pool.ntp.org or pool.ntp.org.

1 Like

By the way, Cloudflare has servers in Azerbaijan*, but time.cloudflare.com has apparently not been added to the az zone…

* Though https://www.cloudflarestatus.com/ says their Baku PoP is currently rerouted elsewhere.

Also, given that az.pool.ntp.org typically has so few servers, you’d be better off to always use asia.pool.ntp.org for your devices (or asia.your_vendor_name.pool.ntp.org). In fact, the NTP pool project is moving to deprecate the country and continent zone names and make them function equivalently to simply pool.ntp.org which uses a IP geolocation database to return servers geographically close to the source of the DNS query.

we have several hundreds of stbs which does not has an ability for remote provisioning.As far as i know ntp server on them configured to poolntporg and i can’t change this.

Just as I experienced with my first post here, it appears someone has “flagged by the community” the original post in this thread, causing it to be “temporarily hidden”. You could argue it should be in a different category but I see no other reason to flag it.


Now,problem is solved. pool.ntp.org resolving this servers:,,,

Thank you, @jafarabdullayev and apologies for the inconvenience! I’m working on a new system for generating the zone data that will in particular improve the small / underserved zones.

@mnordhoff Thanks for posting a snapshot of what you saw at that time. Did you make the first post around 20:30 UTC on the 17th? I am trying to find this in the log and not succeeding yet. In the screenshot below monitor id 11 is nlams1-1a6a7hp and 24 is the recentmedian score. I can’t find a time where the recent median score was about 10.7 and the others really low (though obviously that was happening!)

The problem with the selector switching all the monitors to testing I can see in the logs. It’s not supposed to happen, but glancing at the code it looks like there’s a part where it works out how many changes are allowed assuming monitors are going to be switched TO active status and not the other way around.

Yeah, I noticed that. It’s a red herring (and since fixed). The tool that reports the numbers to the statuspage was including the scoring results, so the first dip was after I disabled the legacy score and the second dip was when I allowed the recentmedian scorer to wait 15 minutes between log entries instead of 10 if the score stayed the same.


The problem with all monitors switching to testing should be fixed in this change. I’ll put it in production this weekend.

1 Like

Well, Discourse says I posted it at 20:32, but I don’t remember. That’s roughly correct, but I don’t know if it’s precisely correct. I habitually edit posts right after making them, and I think Discourse coalesces rapid edits. I don’t know if it fudges the post timestamp. (Discourse shows I edited it once at 20:58, but I believe I edited it multiple times.)

My browser history – which probably only shows the most recent visit if I reload a page? – shows:

20:24:22: https://www.ntppool.org/scores/
20:25:12: https://www.ntppool.org/scores/* (which I didn’t quote in my post)
20:27:43: One of my server pages (to check if the monitoring system was totally broken)
20:29:47: https://www.ntppool.org/scores/
20:30:51: My account page (again to check the monitoring system)

So the copied-and-pasted tables in my post probably date from 20:24:22 and 20:27:43, but they could be a bit earlier.

Hello,this issue appeared again today.
time.pasha-technology.com servers down.@ask Does your update already in production for fast switching queries to another servers?

@jafarabdullayev I know it has been 20 hours since you asked, but are you still experiencing problems?

All 4 servers have been manually removed from the Pool, either by the server operator or by the Pool admins. All of their scores pages (e.g. this one) show “Not active in the pool, monitoring only”.

If I look up az.pool.ntp.org, I get 0 IP addresses. If I look up pool.ntp.org while pretending to be in Azerbaijan (using EDNS Client Subnet), I get 4 IP addresses from other countries in the asia zone.

@ask At 2023-08-27 06:05 UTC, the 4 servers have strange scores again (but, as mentioned above, are monitoring-only).


active			Score
overall score	6.7
testing			Score
ussjc1-1a6a7hp	-59.3
nlams1-1a6a7hp	-57.7
sgsin1-1a6a7hp	-56.9
usewr1-1a6a7hp	-45.8
deksf1-1a6a7hp	-61.3


active			Score
overall score	12.9
testing			Score
ussjc1-1a6a7hp	-72.8
nlams1-1a6a7hp	-74
sgsin1-1a6a7hp	-74.1
usewr1-1a6a7hp	-60.4
deksf1-1a6a7hp	-82.7


active			Score
overall score	-4.8
testing			Score
ussjc1-1a6a7hp	-32.6
nlams1-1a6a7hp	-71.5
sgsin1-1a6a7hp	-38.2
usewr1-1a6a7hp	-24.1
deksf1-1a6a7hp	-70.1


active			Score
overall score	14.5
testing			Score
ussjc1-1a6a7hp	-63.4
nlams1-1a6a7hp	-70.6
sgsin1-1a6a7hp	-70.6
usewr1-1a6a7hp	-54.7
deksf1-1a6a7hp	-71.7

Now,problem is solved ntp.pool.org resolves another ntp servers.

A very similar issue today in Israel.

pool.ntp.org returns only a single server which has a score of 13 when in fact it is not working at all. Effectively pool.ntp.org is not working in Israel.