No modify time requirements

#1

I use GPS +NTP as my reference time. But after I restart ntp service and wait few seconds(about 60s) to get the offset data, I fond the offset will jump, I guess the NTP service change my system time. So I want to asked how can I set in ntp.conf to let ntp just show the offset but not modify my system time or if there is an other reason to cause this problem. I will be grateful if anyone can reply.

0 Likes

#2

I don’t think there is any setting in the config, but I would think there is a startup flag…

If you add other NTP servers to your config, then NTPD should startup and if your GPS is wildly off it should show it. Have you checked your GPS output? Perhaps it was affected by the GPS rollover and it thinks it’s 1999?

0 Likes